Se sei già registrato           oppure    

Orario: 24/09/2020 13:06:34  

 

Energia Alternativa ed Energia Fai Da Te > Applicazioni E Realizzazioni Pratiche

VISUALIZZA L'ALBUM

Pagine: (167)  < ...  37   38   39   40   41   42   43   44   45   46   [47]   48   49   50   51   52   53   54   55   56   57  ...>    (Ultimo Msg)


Homemade Inverter "modulo DC/AC"
FinePagina

salvatre

Avatar
Watt


Gruppo:Utente
Messaggi:75

Stato:



Inviato il: 30/05/2014 11:13:31

Ciao,
ho ricontrollato stamane e non mi pare di aver fatto errori grossolani.
Ieri sera avevo fatto così:
• LH2, LH4, RH4 e RH2 isolati nel senso di liberi, non connessi ad alcunché (ma con le loro resistenze di gate 4R7, 1N4148 e resistenza 10K tra G e S montate al loro posto sulla millefori, come da schema LINK);
• LH3 e RH3 connessi a massa per il tramite di 2 resistenze da 100 ohm.
I risultati delle misurazioni sono quelli su riportati LINK.
Quando ho tolto queste 2 resistenze e connesso direttamente a massa LH3 e RH3, i due IR2110 (appena sostituiti) si sono arroventati esplodendo!
Sinceramente, pur essendo uno che non demorde facilmente, comincio ad essere demoralizzato da tanti insuccessi!


xElettro
le resistenze da 100 ohm andavano connesse tra massa e quali uscite?



Modificato da salvatre - 30/05/2014, 11:24:10
 

ElettroshockNow

Avatar
GigaWatt


Gruppo:Utente
Messaggi:4656

Stato:



Inviato il: 30/05/2014 12:08:56

http://www.energialternativa.info/public/newforum/ForumEA/A/rps20140530_120535_592.jpg
Ho riprodotto il test confermando che doveva funzionare.
Ma non facevi prima a stampare il mio PCB perché sicuramente c'è un errore che ciclicamente ti sfugge .....

 

ElettroshockNow

Avatar
GigaWatt


Gruppo:Utente
Messaggi:4656

Stato:



Inviato il: 30/05/2014 14:25:50

Connessioni necessarie per il Test:

Pin1=Portare al Negativo (In questa situazione simula assorbimento nullo)
Pin2=Negativo
Pin3= OUT LH2 ,forma in uscita quadra
Pin4=Negativo
Pin5=Portare al Negativo solo per il TEST (LH3)
Pin6= OUT LH4,forma in uscita quadra sfasata rispetto al Pin3 con DeadTime
Pin7=Negativo
Pin8= OUT RH2,forma in uscita sinusoidale digitalizzata
Pin9=Portare al Negativo solo per i TEST (RH3)
Pin10= OUT RH4,forma in uscita sinusoidale digitalizzta sfasata rispetto al Pin8
Pin11=Negativo
Pin12=Tensione pilotaggio Gate (dai 10Vdc ai 18Vdc)
Pin13=Negativo
Pin14=+5Vdc
Pin15=Feedback Tensione (regolare a 3V attraverso un Trimmer)
Pin16=lasciare libero
Pin17=lasciare libero

Posto un video riepilogativo delle prove da eseguire per confermare il buon funzionamento del modulo



Ciao
ElettroshockNow

 

salvatre

Avatar
Watt


Gruppo:Utente
Messaggi:75

Stato:



Inviato il: 30/05/2014 17:35:15

x Elettro
Ho due cose da dire:
1. Esprimerti tutta la mia ammirazione per la chiarezza e la semplicità delle tue spiegazioni e del tuo video. GRAZIE
2. Prima di distruggere la scheda verde (che, come la rossa del tuo video, non aveva protezione da sottotensione né la possibilità di far funzionare il minidisplay lillipuziano della EGmicro), avevo trovato, con una tensione di alimentazione gate di 13V DC, queste tensioni a vuoto, senza carico: 9,8V sul pin 10; 6,2V sul pin 8; 9,7V sul pin 6 e 6,1V sul pin 3. Come vedi non sono piccole differenze di pochi decimi di volt, ma di differenze di più di 2,5 volt! E' una cosa normale?
Comunque, con l'ultima scheda rimastami, ripeterò passo passo e senza variare nulla la tua dimostrazione in video e Vi farò sapere a tutti risultati (ho anche un amico che mi aiuterà con il suo oscilloscopio, che io non ho!).
Ciao a tutti.

 

ElettroshockNow

Avatar
GigaWatt


Gruppo:Utente
Messaggi:4656

Stato:



Inviato il: 30/05/2014 18:19:19

Tu non sai quanto mi fa' male non vederti cogliere i frutti di tanto lavoro.
La tua realizzazione è bellissima (la millefori mi affascina) , ma c'è qualcosa che ci sfugge .
Ricomincia dal test e solo se otterrai valori simili prosegui

Però il perchè siano saltati gli IR mi confonde molto ..... e da qui non mi viene in mente niente che potrebbe mettere in evidenza l'anomalia o aiutarti nella ricerca .... Porcapaletta

 

ElettroshockNow

Avatar
GigaWatt


Gruppo:Utente
Messaggi:4656

Stato:



Inviato il: 31/05/2014 15:03:53

Visto che la scheda si trovava sulla Breadboard ho eseguito un test veloce veloce riscontrando:

La tensione di feedback passa attraverso un comparatore a finestra avente come soglia superiore 3,03V e come soglia inferiore 3,01V.
Se la tensione di feedback oltrepassa la soglia superiore l'EG8010 riduce il massimo Duty Cycle in uscita sui pin 8 e 10 riducendo di conseguenza la tensione in uscita.
La riduzione prosegue fino a che la tensione scende sotto la soglia superiore.
Se invece la tensione risulta inferiore alla soglia inferiore ,l'EG8010 aumenta il duty fino al massimo valore .
In pratica il microcontrollore non fà niente se si rientra tra le soglie.

Poi ho misurato la velocità di risposta (empirica ) immettendo degli impulsi con Tempo ON regolabile.
Se l'impulso fà oltrepassare la soglia superiore per un tempo maggiore a 800µS l'integrato interviene.

Ciao
ElettroshockNow

 

salvatre

Avatar
Watt


Gruppo:Utente
Messaggi:75

Stato:



Inviato il: 01/06/2014 13:48:38

Facendo seguito al mio precedente post (link), ho fatto sì un errore grossolano.
Alcune settimane fa avevo preparato su una millefori un modulo tester x “sperimentare” le schede driver EGS002, fornito di potenziometri di simulazione dei sensori di corrente, tensione e temperatura, di check point multipli per le varie misurazioni e di connessioni facilmente collegabili/scollegabili: il modulo tester è qui in fondo al post.
L’errore : nell’ultimare il modulo dovevo collegare la massa dell’alimentazione ad “alta” tensione dei mosfet con quella a “basse” tensioni della schedina (pin 7 o 2), ma per distrazione l’ho collegata ai due pin 10 e 6; poi ho fatto le misurazioni di cui al post succitato con i risultati che conoscete.
Adesso ho corretto l’errore, ho di nuovo sostituito gli IR 2110 sulla scheda verde e ricontrollato le tensioni, constatando che la situazione di fatto non è cambiata (tensione di 6,1V sui pin 8 e 3 e di 11,9V sui pin 10 e 6). Di conseguenza suppongo di aver danneggiato, dopo l’ultimo misfatto, anche il chip EG8010. Voi cosa ne pensate?
Cambierò domani anche i due IR2110 sulla scheda rossa e ripeterò la prova, ma sono quasi sicuro che avrò gli stessi risultati.
Ciao a tutti



Immagine Allegata: fronte_retro.png
 
ForumEA/A/fronte_retro.png



Modificato da salvatre - 02/06/2014, 10:53:54
 

ElettroshockNow

Avatar
GigaWatt


Gruppo:Utente
Messaggi:4656

Stato:



Inviato il: 02/06/2014 18:23:16

CITAZIONE (salvatre, 01/06/2014 13:48:38 ) Discussione.php?55031252&47#MSG721


Cambierò domani anche i due IR2110 sulla scheda rossa e ripeterò la prova, ma sono quasi sicuro che avrò gli stessi risultati.

Misura la tensione sui PWMOUT.
Dovrai leggere circa 2.5V.
Se leggerai 2.5V ,ma in uscita dello stesso canale una tensione diversa dai circa 6V allora è l'IR2110 danneggiato ,altrimenti è l'EG8010.

Per conferma rimuovi gli IR e riesegui la misura .
Con led Acceso e feedback tensione (PIN15)a 3V devi avere circa 2.5V.
http://www.energialternativa.info/public/newforum/ForumEA/A/EG8010%20ProvaOut.jpg

 

salvatre

Avatar
Watt


Gruppo:Utente
Messaggi:75

Stato:



Inviato il: 03/06/2014 11:05:53

Ho eseguito le misurazioni consigliate da Elettro sulla mia scheda EGS002 verde (la rossa adesso non l’ho qui da me).
Con tensioni di alimentazione di 13,1V sul pin12, di 5,0V sul pin 14 e di 3,02V sul pin 15, ho trovato:
• Su l’EG8010:
• Pin30 = 2,23V
• Pin29= 2,23V
• Pin 28= 2,41V
• Pin 27= 2,41V

• Su la scheda driver EGS002:
• Pin 10= 12,3V
• Pin 8= 6,1V
• Pin 6= 12,3V
• Pin 3= 6,1V

Faccio presente che gli IR2110 sono stati appena sostituiti (per la seconda volta!).
Cosa ne pensate di questi risultati?

PS: non ho fatto la riprova rimuovendo gli IR2110, perché non ho qui la stazione dissaldante.
Siccome sono testardo e cocciuto, ho ordinato una nuova scheda EGS002 blu ma arriverà fra 50 giorni!

 

ElettroshockNow

Avatar
GigaWatt


Gruppo:Utente
Messaggi:4656

Stato:



Inviato il: 03/06/2014 13:31:31

Ma la tua scheda monta i transistor per evitare gli incroci ?
http://www.energialternativa.info/public/newforum/ForumEA/A/TransistorEG.jpg
Rimuovili e testali sono molto probabilmente loro

Una volta rimossi potresti ponticellare singolarmente i collettori con gli emettitori e misurare nuovamente l'uscita sugli IR che dovranno darti i circa 6V .

Ciao

 

ElettroshockNow

Avatar
GigaWatt


Gruppo:Utente
Messaggi:4656

Stato:



Inviato il: 04/06/2014 10:21:54

http://www.energialternativa.info/public/newforum/ForumEA/A/Nuovo%20Inverter_2.jpg

Stavo con la cazzuola in mano ... quando mi son chiesto .... ma ...
ma perché i diodi di ricircolo non dovrebbero recuperare le extratensioni.
Nello schema non sono riportati , ma su ogni IGBT c'è un diodo con il Catodo sul collettore.

Qualsiasi cosa accada la tensione in uscita non potrà mai oltrepassare le soglie di alimentazione.

Se ci troviamo nell'istante di apertura di T3-T4 (quindi -350V in uscita) avremo una extratensioni positiva che se oltrepassa i +350 manda in conduzione i diodi D1-D2.

Stesso discorso se si aprono T1-T2 (+350V in uscita) ....avremo una extratensione negativa ... e se otrepassasse i -350V entrerebbero in conduzione D3-D4.

Sicuramente per il bene del carico dobbiamo evitare queste extratensioni ( ci penserà il filtro), ma il ponte è protetto dagli ottimi condensatori a bassissimo ESR.

Cosa mi sfugge ? ... è troppo semplice come soluzione

Ciao
ElettroshockNow i

 

scinty

Avatar
GigaWatt


Gruppo:Utente
Messaggi:734

Stato:



Inviato il: 04/06/2014 21:02:16

bravo.... molto bravo, più mille direbbe un mio vecchio professore!
però in parte sbagli quando dici che per i picchi ci penserà il filtro certo ovviamente spiana abbastanza ma il l'onda distorce lo stesso



---------------
14 pannelli mono da 250Wp 24 pannelli amorfi Sharp da 130Wp banco batterie 48V 225Ah survoltore 5000W homemade inverter 6000VA trifase homemade modalità di interconnessione ibrida Scinty-Kirchoff (nodo DC) secondo inverter di supporto mppt inverter Sunny boy 3000(nodo AC)

 

ElettroshockNow

Avatar
GigaWatt


Gruppo:Utente
Messaggi:4656

Stato:



Inviato il: 04/06/2014 21:20:28

Grazie per il bravo .... onorato.
E come cavolo le blocco le extratensioni se è il carico a generarle !!!

Un robusto snubber dopo il filtro passa basso forse è la soluzione

 

kekko.alchemi

Avatar
GigaWatt


Gruppo:Utente
Messaggi:5226

Stato:



Inviato il: 04/06/2014 23:00:55

Si infatti così è perfetto! Il problema sorge con il push-pull puro con soli due mosfet, in quel caso le extratensioni vengono cortocircuitate, perdendo efficienza.

Kekko



Modificato da kekko.alchemi - 04/06/2014, 23:04:34


---------------
L'universo è dominato dagli estremi, l'infinitamente grande e l'infinitamente piccolo.
Ma l'equilibrio è ciò che plasma la materia di cui siamo fatti.
by kekko

 

scinty

Avatar
GigaWatt


Gruppo:Utente
Messaggi:734

Stato:



Inviato il: 04/06/2014 23:12:32

dai kekko si è vero lo snubber consuma potenza ma quanto 2 forse 3 Watt e cosa sono in mezzo a 3 magari 5kW lo snubber è importantissimo!!!!!



---------------
14 pannelli mono da 250Wp 24 pannelli amorfi Sharp da 130Wp banco batterie 48V 225Ah survoltore 5000W homemade inverter 6000VA trifase homemade modalità di interconnessione ibrida Scinty-Kirchoff (nodo DC) secondo inverter di supporto mppt inverter Sunny boy 3000(nodo AC)

 
 InizioPagina
 

Pagine: (167)  < ...  37   38   39   40   41   42   43   44   45   46   [47]   48   49   50   51   52   53   54   55   56   57  ...>    (Ultimo Msg)

Versione Mobile!

Home page       TOP100-SOLAR      Home page forum