Se sei già registrato           oppure    

Orario: 24/02/2020 11:44:08  

 

Energia Alternativa ed Energia Fai Da Te > PPTEA

VISUALIZZA L'ALBUM

Pagine: (114)  < ...  84   85   86   87   88   89   90   91   92   93   [94]   95   96   97   98   99   100   101   102   103   104  ...>    (Ultimo Msg)


PPTEA- Processore Per Tutti
FinePagina

nennos

Avatar
KiloWatt


Gruppo:Utente
Messaggi:227

Stato:



Inviato il: 27/4/2013,09:12

ciao bolle
volevo chiederti una cosa
sto realizzando un adattatore per display 2w e non ho capito una cosa
dallo schema elettrico manca il numero piedino 4 del cd 4094
mi diresti gentilmente come va piazzato
ps ho recuperato un hcf4094be pensi possa andar bene
come sempre
grazie
ciao

 

Master Digit

Avatar
GigaWatt


Gruppo:Utente
Messaggi:1418

Stato:



Inviato il: 27/4/2013,17:47

Provata la versione 4.1.8 e con i miei programmi EABasic funziona tutto.
L'unica cosa che ho notato è che se scrivo:
10 A="Pulsante ON"
le lettere ON diventano blu invece di rosse come per le altre versioni, come se ON venisse considerato un comando.

Un altra cosa che ho notato è che caricando il Firmware, alla fine viene scritta una data.
Non è che il software PPTEA è come il Latte? faccine/blink.gif
Cioè, che ha una data di scadenza? faccine/cry.gif

La versione 4.1.8 l'ho provata con la EEprom 24lc32 e finalmento ho potuto aggiungere dei dati da inviare alla mia pagina Web faccine/wink.gif

X nennos
Nello schema elettrico mancano anche i Pin 9-10 e 11 oltre al 4 del CD4094 in quanto non vanno collegati a nulla, li puoi lasciare tranquillamente così.
Il tuo HCF4094 è identico al CD4094, vai tranquillo.

Master Digit



---------------
Sono sempre disponibile...quando ci sono!

 

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 27/4/2013,17:56

CITAZIONE (Master Digit @ 27/4/2013, 18:47)
Un altra cosa che ho notato è che caricando il Firmware, alla fine viene scritta una data.

Quando faccio l'immagine del PPTEA rimane il codice che scrivo...in genere carico il codice della versione di consegna...ma sono solo pochi byte...il resto rimane inalterato...quindi c'è la possibilità che rimanga del codice.
Per curiosità posti il dato? faccine/smile.gif

CITAZIONE (Master Digit @ 27/4/2013, 18:47)
Non è che il software PPTEA è come il Latte? faccine/blink.gif
Cioè, che ha una data di scadenza? faccine/cry.gif

Assolutamente no...non ha scadenza...sarebbe una cosa molto scorretta...non faccio/facciamo di queste cose.


CITAZIONE (Master Digit @ 27/4/2013, 18:47)
10 A="Pulsante ON"
le lettere ON diventano blu invece di rosse come per le altre versioni, come se ON venisse considerato un comando.

Il colore del compilatore è un po fessacchiotto...non capisce i doppi apici...vediamo di rimediare!



---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 

Master Digit

Avatar
GigaWatt


Gruppo:Utente
Messaggi:1418

Stato:



Inviato il: 27/4/2013,18:01

Grande Bolle!!! faccine/clap.gif faccine/clap.gif faccine/clap.gif faccine/clap.gif

Master Digit



---------------
Sono sempre disponibile...quando ci sono!

 

nennos

Avatar
KiloWatt


Gruppo:Utente
Messaggi:227

Stato:



Inviato il: 27/4/2013,18:18

ciao masterdigit
grazie per le info a presto
ciao

 

MarKoZaKKa

Avatar
GigaWatt


Gruppo:Utente
Messaggi:1881

Stato:



Inviato il: 29/4/2013,07:05

CITAZIONE (NonSoloBolleDiAcqua @ 26/4/2013, 13:31)
Questo è l'algoritmo?

Mi pare di averlo visto su qualche sito riguardante il MODBUS; non ricordo chi e dove mi parlò del MODBUS, riguardo alla mia domotica, ricordo che dopo averne lette le specifiche, mi parve un dejavu faccine/smile.gif. Ora con le evoluzioni della v4 in realtà sarebbe (forse, mi manca come fare il bit-shift) possibile implementare il CRC nel codice EABasic, ma un calcolo di un qualsiasi CRC nel FW, visto che comunque usiamo le comms seriali, ci starebbe bene. Vedi tu.



---------------
Tecnico qualificato in clownerie
Windsurfer a tempo perso
Slalomaro senza speranze

 

alessio287

Avatar
MegaWatt


Gruppo:Utente
Messaggi:306

Stato:



Inviato il: 29/4/2013,20:07

Ciao,

volevo segnalare un fatto visto che è una situazione che si è verificata 2 volte in tempi diversi.

Ho il PPTEA con la versione FW 4.1.8

Il fatto è questo: ho staccato la USB dall'alimentatore esterno, riattaccata, si accende il display con le scritte precedenti, ma non riparte.

Provata diverse volte

Modo di sblocco è riattaccarla alla USB del PC con il compilatore e rifacendo la sincronizzazione seriale; allora se la riattacco all'alimentatore esterno riparte.

2 volte identiche...

faccine/sad.gif

Bye
Alessio287

 

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 29/4/2013,23:02

Ok, domani controllo...salva il codice che se non riesco a replicarlo devi darmelo!

CITAZIONE (alessio287 @ 29/4/2013, 21:07)
ho staccato la USB dall'alimentatore esterno, riattaccata, si accende il display con le scritte precedenti, ma non riparte.

Cmq è strana questa cosa....come fa il display dopo l'assenza di alimentazione a presentare le scritte precedenti...mmmmm faccine/blink.gif
Vedo di indagare...cmq sta arrivando la 4.1.9 con le call dentro la condizione dell'IF.
Mi raccomando ...congela il codice in eabasic.
faccine/smile.gif



---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 

alessio287

Avatar
MegaWatt


Gruppo:Utente
Messaggi:306

Stato:



Inviato il: 29/4/2013,23:12

Ciao Bolle,

guarda... la priva volta non ci ho dato peso.. a ogi l'ha rifatto... così come ti ho descritto... stacca e riattacca ali e non succedeva nulla... solo con la sincro seriale s'è sbloccato... giuro

Alessio287

 

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 29/4/2013,23:18

Ti credo , ti credo...considera che di varianti sul firmware sono state fatte veramente poche....quasi tutto ha impatto sul compilatore...l'unica cosa degna di nota è stato aumentare lo stack delle chiamate nidificate...ricontrollo la memoria ...faccio un giro di test...e visto che ci stiamo partoriamo la nuova versione....cmq tieni gli occhi ben aperti...segnala tutto...anche problemi presunti. faccine/smile.gif

CITAZIONE (alessio287 @ 30/4/2013, 00:12)
guarda... la priva volta non ci ho dato peso.. a ogi l'ha rifatto... così come ti ho descritto... stacca e riattacca ali e non succedeva nulla... solo con la sincro seriale s'è sbloccato... giuro

Ma hai ricaricato il codice per farlo sbloccare...oppure è bastato sincronizzarlo?



---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 

alessio287

Avatar
MegaWatt


Gruppo:Utente
Messaggi:306

Stato:



Inviato il: 30/4/2013,08:48

Ciao,

sincronizzarlo


Bye
Alessio287

 

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 30/4/2013,08:51

Non mi torna...non mi torna...non mi torna...forse è saltata la connessione con la usb del pc.
fammi capire è saltata la diagnostica con il pc ma il PPTEA continuava a funzionare (cioè il display andava etc) ma la connessione con il PC no....oppure nemmeno il PPTEA andava?



---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 

alessio287

Avatar
MegaWatt


Gruppo:Utente
Messaggi:306

Stato:



Inviato il: 30/4/2013,09:07

Ciao Bolle,

capisco che nn è semplice se non si vede...

allora...

PPTEA funzionante, gli stacco alimentazione USB (non è attaccato PC, ma DCDC esterno), lo riattacco e non parte + rivisualizzando l'ultima schermata sul display. Cmq PPTEA fermo e per farlo ripartire mi sono accorto che basta risincronizzarlo (la 1a volta pensavo di dover ricaricare il sw, ma nella procedura per collegarlo al compiler mi sono accorto che alla sincro è ripartito)

Bye
Alessio287

PS: ho fatto una versione 0 di webserver in python con pagina di scelta dati da visualizzare

 

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 30/4/2013,09:15

Aiutami che non ho capito....mi occorre capire la sequenza e cosa stacchi/attacchi.
Riassumo le cose principali: PPTEA alimentato con alimentazione esterna al PC, il PC funge solo da visualizzatore dati che transitano mediante USB...giusto?
1.PPTEA alimentato con alimentazione esterna e connesso al PC mediante USB...tutto procede.
2.Stacchi la USB dal PPTEA con alimentazione esterna agganciata.
3.Questa è la fase che non capisco
4.Riagganci la porta USB (sempre con alimentazione esterna connessa) e il PPTEA non parte più.
5.Sincronizzi e tutto si riavvia.
Giusto?



---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 

alessio287

Avatar
MegaWatt


Gruppo:Utente
Messaggi:306

Stato:



Inviato il: 30/4/2013,09:21

Ciao,

premesso che mi è successo 2 volte solo ed ora ho riprovato a staccare riattaccare e ha funzionato.

1) PPTEA non è attaccato PC, ma al RASP... USB esterna e SOLO alimentazione
poi il resto è ok quanto dici


Bye
Alessio287

 
 InizioPagina
 

Pagine: (114)  < ...  84   85   86   87   88   89   90   91   92   93   [94]   95   96   97   98   99   100   101   102   103   104  ...>    (Ultimo Msg)

Versione Mobile!

Home page       TOP100-SOLAR      Home page forum