Se sei già registrato           oppure    

Orario: 24/02/2020 11:46:29  

 

Energia Alternativa ed Energia Fai Da Te > PPTEA

VISUALIZZA L'ALBUM

Pagine: (114)  < ...  85   86   87   88   89   90   91   92   93   94   [95]   96   97   98   99   100   101   102   103   104   105  ...>    (Ultimo Msg)


PPTEA- Processore Per Tutti
FinePagina

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 30/4/2013,09:27

Non capisco...ma se non è connesso al PC come fai a sincronizzarlo?



---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 

alessio287

Avatar
MegaWatt


Gruppo:Utente
Messaggi:306

Stato:



Inviato il: 30/4/2013,09:44

allora..

- il PPTEA non è normalmente collegato al PC, ma al RASP
- è alimentato da un DCDC esterno via USB (solo ali)
- stacco e riattacco da questo e nulla
- allora mi dico... sarà saltato il SW ed allora penso di ricaricarlo
- prendo il PC, apro compilatore e sincronizzo PPTEA sulla USB dl PC e comincia a rifunzionare

Bolle questo blocco è assolutamente randomico e successo 2 volte...

Bye
Alessio287

 

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 30/4/2013,10:03

Cerco di entrare nel dettaglio...tanto per parlare...tanto per capire meglio...tanto per far capire agli altri cosa si può fare con PPTEA/RASPBERRY.

il PPTEA è agganciato alla porta usb del RaspBerry che gli fornisce la sola alimentazione.
il RaspBerry è agganciato al suo alimentatore +5V
Stacchi il cavo USB che alimenta il PPTEA dal RaspBerry...dopo qualche secondo la agganci nuovamente e il PPTEA con il suo programma non parte...fai questa cosa diverse volte e nulla.
Poi agganci il cavo USB al PC sincronizzi e si sincronizza. Ristacchi il cavo USB e lo agganci al RaspBerry e tutto riprende a funzionare.
Giusto?

CITAZIONE (alessio287 @ 30/4/2013, 10:44)
...sarà saltato il SW ed allora penso di ricaricarlo

Questo non può accadere...il SW non può 'saltare'...va su EEPROM...non si può cancellare. L'unico che può modificare il codice è il compilatore oppure fare attenzione ai comandi di scrittura della EEPROM.
Occhio che se si scrive '0' nella cella '0' ...allora il PPTEA non parte ...interpreta questa cosa come l'assenza di codice al suo interno.



---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 

alessio287

Avatar
MegaWatt


Gruppo:Utente
Messaggi:306

Stato:



Inviato il: 30/4/2013,10:09

Aspe...

ho un convertitore 24v - 5v esterno collegato alle batterie

a questo sono collegati sia il RASP che il PPTEA


Per il resto è tutto giusto quanto hai scritto

Bye
Alessio287

 

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 30/4/2013,10:19

Perfetto...non cambia la situazione.
Una cosa...utilizzi il bit 15? Se non lo utilizzi puoi mettere un beeper , un altoparlantino (va bene un qualsiasi altoparlante) etc...e la prima istruzione che devi far fare il PPTEA è un BEEP.
Di fatto il tuo PPTEA nella sequenza non fa altro che essere alimentato da un altro alimentatore...non sa a priori chi sia...quindi mi sembra molto strano il tutto. L'unica cosa che fai è alimentarlo con un'altra massa...non vorrei che il problema sia nella seriale che colleghi al Rasp.
Quando agganci e sganci...lasci la seriale connessa al RaspBerry? Forse è il problema è proprio questo.
Se ti ricapita...oltre a staccare l'almentazione stacca anche la seriale...e riaggancia...vediamo se il problema è illo.



---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 

alessio287

Avatar
MegaWatt


Gruppo:Utente
Messaggi:306

Stato:



Inviato il: 30/4/2013,11:04

Ok Bolle,

se ricapita provo come dici tu.

il bit15 lo uso (anche il 14)... il beep funziona solo sul 15?

Bye
Alessio287

 

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 30/4/2013,12:56

CITAZIONE (alessio287 @ 30/4/2013, 12:04)
il beep funziona solo sul 15?

Si, tutte le note sono utilizzabili solo li...cmq sono sempre più sicuro che riguarda problemi di connessione con la seriale PPTEA/RaspBerry...perchè rimane alimentato il rasp e se da il livello alto ...rialimenta in modo sporco il PPTEA...quindi il PPTEA non effettua il reset ( spiegato anche il motivo per cui il display riparte con la stessa situazione) ...capito cosa intendo?
Cmq bene...se il problema è solo quello siamo a cavallo...quanto prima faccio uscire la 4.1.9 con le CALL che possono essere messe anche nella condizione IF...e sistemata ai colori nelle stringhe dell'editor del compilatore (segnalazione di MasterDigit).
Ciao
Bolle
faccine/smile.gif



---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 30/4/2013,13:21

Consegna PPTEA ADVANCED 4.1.9
AGGIORNATE....AGGIORNATE....SU SU...ABBIAMO QUASI COMPLETATO IL TUTTO faccine/w00t.gif faccine/smile.gif
Da questa versione è consentito la chiamata ad una call all'interno della condizione di un if.
Nell'esempio il programma risponde con un "VERO P=1".



PRAGMA NO_NUM_LINE
'

SUB
MAIN
a=CALL PLUTO ' CIAO
IF
CALL CIAO(3)=2 THEN :VERO ELSE :FALSO ' ESEMPIO CONDIZIONE DI CHIAMATA CON CALL...
:VERO

PRINT "VERO"
GOTO :FINE
:FALSO

PRINT "FALSO"
GOTO :FINE
:FINE

IF
CALL PLUTO THEN P=1 ' ESEMPIO CONDIZIONE DI CHIAMATA CON CALL...
PRINT
"P="&P
END

SUBEND



SUB
CIAO(par1)
CIAO=par1-1
SUBEND



SUB
PLUTO
PLUTO=27
SUBEND


Bolle



Scarica allegato

PPTEA4_1_9.rar

( Numero download: 65 )



---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 

alessio287

Avatar
MegaWatt


Gruppo:Utente
Messaggi:306

Stato:



Inviato il: 1/5/2013,10:15

Ciao Bolle,

IF ERROR THEN CALL STAMPA_ERRORE


Fase 2: Load Program in Memory mysolar_2_15.pea
PRECOMPILING ERROR: IF ERROR THEN CALL STAMPA_ERRORE SINTAX ERROR CALL!


Nella 4.1.8 funzionava... cosa non ho letto?

Bye
Alessio287

 

Luca450Mhz

Avatar
GigaWatt


Gruppo:Utente
Messaggi:3023

Stato:



Inviato il: 1/5/2013,14:41

Non so cosa pensare... ho due PPTEA, uno su millefori fatta da me, e una KSB.
Prima uno, e a distanza di qualche giorno l'altro... non funzionano più..
All'improvviso, smettono di funzionare.. oggi ho fatto delle modifiche al programma, l'ho caricato, e poi basta.. morto!!!
Non lo riconosce neanche più il pc.. sia con alimentazione da alimentatore switching, sia da sola USB.
Ho provato con due pc diversi, niente da fare..
Però sono riuscito, per entrambi, a caricare il firmware aggiornato.
Su uno dei due, ho il display, viene inizializzato con i quadratini neri, e così rimane. Ma tutti e due non rispondono più a nessun input... :'(
Potrebbe essere che qualche componente si sia "distrutto"? Un condensatore, il quarzo, non so cosa altro...........
Stavo testando il Ronwal sensor come lo ha nominato ElettroshockNow.. uffa..

P.S. la temperatura potrebbe essere un problema?



---------------
Pannelli: 4395 Wp policristallini. Inverter UPS PSW7 6kW 48V toroidale con switch comandato dal mio sistema di domotica (ESP8266). Regolatore di carica: Finalmente di nuovo il PCM8048!
Batterie: 24 elementi trazione pesante 315Ah C5 48V
Impianto illuminazione giardino: 300Wp amorfi, regolatore MPPT EpSolar 20A, inverter onda pura 300W, 100Ah batterie auto

 

ronwal

Avatar
GigaWatt


Gruppo:Utente
Messaggi:1729

Stato:



Inviato il: 1/5/2013,14:59

Possono essere molte cose....controlla il quarzo e i vari condensatori.... Poi un dai un occhio al collegamento usb.... Mi ha dato molti problemi questa ultima cosa...



---------------
6 bosch csi 240 mono, 9 ldk 225 poly,
Outback flex max 60, psw 7 advance 4kw 48v,
24 elementi 400ah c 5 tubolari

 

MarKoZaKKa

Avatar
GigaWatt


Gruppo:Utente
Messaggi:1881

Stato:



Inviato il: 1/5/2013,15:58

Luca, ma non ti funziona più oppurenon ti viene riconosciuto dal PC, mentre in realtà il codice eabasic continua a girare? Io ho avuto questo problema con la KSB-II, ed ho incolpato prima il pic, poi la scheda, poi il cavo, (con le vecchie schede tutto funzionava)... infine, ho rimosso dal device manager l'hub usb della mainboard, reinstallato i drivers ed ora funziona tutto... mi sono accorto di questo problema usando una porta collegata ad un'altro hub della mb, mai usata col PPTEA, e mi ha riconosciuto subito la scheda nuova... mah...



---------------
Tecnico qualificato in clownerie
Windsurfer a tempo perso
Slalomaro senza speranze

 

nennos

Avatar
KiloWatt


Gruppo:Utente
Messaggi:227

Stato:



Inviato il: 1/5/2013,16:41

ciao luca 450mhz
anche io ho avuto un problema simile al tuo
o pensato di tutto scartando quello che per me era impossibile
e invece era la causa del guasto
era il quarzo andato
senza toccare nulla ho provato a collegare il pptea al pc e non riconosceva niente o collegato un 'altro quarzo appoggiando i
contatti a quello esistente e per incanto a ripreso a funzionare
prova cosi
ciao

 

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 1/5/2013,18:10

CITAZIONE (alessio287 @ 1/5/2013, 11:15)
IF ERROR THEN CALL STAMPA_ERRORE


Fase 2: Load Program in Memory mysolar_2_15.pea
PRECOMPILING ERROR: IF ERROR THEN CALL STAMPA_ERRORE SINTAX ERROR CALL!


Nella 4.1.8 funzionava... cosa non ho letto?

Non mi da errore...ho provato anche a compilare la versione che hai postato cioè la mysolar_2_12,eab ma non noto problemi....postami tutto il codice che verifico.
Ciao
Bolle



---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 

alessio287

Avatar
MegaWatt


Gruppo:Utente
Messaggi:306

Stato:



Inviato il: 1/5/2013,19:25

Ciao Bolle,

eccola


Bye
Alessio287


Scarica allegato

mysolar_2_15.eab ( Numero download: 76 )

 
 InizioPagina
 

Pagine: (114)  < ...  85   86   87   88   89   90   91   92   93   94   [95]   96   97   98   99   100   101   102   103   104   105  ...>    (Ultimo Msg)

Versione Mobile!

Home page       TOP100-SOLAR      Home page forum