Se sei già registrato           oppure    

Orario: 13/11/2019 11:09:11  

 

Energia Alternativa ed Energia Fai Da Te > PPTEA

VISUALIZZA L'ALBUM

Pagine: (72)   1   2   [3]   4   5   6   7   8   9   10   11   12   13   14   15   16   17   18   19   20  ...>    (Ultimo Msg)


SOLAR PLATFORM
FinePagina

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 16/8/2012,15:26

Dovrebbe girare anche con il firmware vecchio...quanto prima faccio una verifica.

CITAZIONE (PinoTux @ 16/8/2012, 13:23)
Non ho capito il discorso del carattere "&"
Devo ancora provare, ma non capisco se il problema riguarda il compilatore oppure il codice HTML?
Il codice va bene così o bisogna sostituire qualcosa?

Ciao Pino,
nessun problema mascroscopico...solo un dettaglio ...ma ora non ho tempo....lo spiegherò meglio con calma. Il codice è quello ma rimango in attesa di sapere se l'eseguibile viene eseguito e se vedere la schermata in allegato.
Ciao
Bolle







---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 

ronwal

Avatar
GigaWatt


Gruppo:Utente
Messaggi:1729

Stato:



Inviato il: 16/8/2012,16:18

Ok Bolle....funziona, rimane un pelo piccolino ma e' uno spettacolo.......(eseguibile)....appena torno dalle ferie provo a mandare dentro il pptea il codice, cosi' vediamo se funziona con la v. 216c



---------------
6 bosch csi 240 mono, 9 ldk 225 poly,
Outback flex max 60, psw 7 advance 4kw 48v,
24 elementi 400ah c 5 tubolari

 

PinoTux

Avatar
GigaWatt


Gruppo:AMMINISTRATORE
Messaggi:3443

Stato:



Inviato il: 16/8/2012,17:28

Ho provato il codice simulando la corrente e la tensione con dei trimmer mentre per la temperatura ho la sonda e tutto gira normalmente; sul compilatore visualizzo i dati nella finestra: START, i tre valori e lo STOP.
Chiuso il compilatore, apro l'eseguibile del grafico e la finestra della COM (4 nel mio caso) diventa verde come pure la finestra network...
Solamente che sul grafico non viene visualizzato nulla, tutto rimane fermo e i quattro file hanno contenuto zero...non sono sicuro che l'eseguibile sia ben sincronizzato/agganciato, succede pure qualche volta con il compilatore che, pur risultando verde, non comunica...
altro non saprei...



---------------
"Fatti non foste a viver come bruti, ma per seguir virtute e canoscenza"
http://iv3gfn.altervista.org/
http://pptea.altervista.org/

 

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 16/8/2012,18:55

Ok perfetto, grazie è normale che non visualizzi nulla...quanto prima posto il nuovo eseguibile ... mi serviva solo sapere se le dll e le ocx fossero ok!
Ciao
Bolle



---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 

PinoTux

Avatar
GigaWatt


Gruppo:AMMINISTRATORE
Messaggi:3443

Stato:



Inviato il: 16/8/2012,19:07

l'hai fatto per vedere se seguivamo il lavoro ehhh! faccine/laugh.gif



---------------
"Fatti non foste a viver come bruti, ma per seguir virtute e canoscenza"
http://iv3gfn.altervista.org/
http://pptea.altervista.org/

 

marpad65
KiloWatt


Gruppo:Utente
Messaggi:230

Stato:



Inviato il: 17/8/2012,01:02

CITAZIONE (NonSoloBolleDiAcqua @ 14/8/2012, 21:28)
X marpdap ,
non ho capito la domanda.
Bolle

sto utilizzando il grafico con le 5 temperature adattato alle mie esigenze. Volevo capire se utilizzavi lo stesso principio o no. Postando il codice eabasic hai gia risposto .... grazie.
Per le verifiche sul PIC dopo il 22

Ciao a tutti

Marco

 

ronwal

Avatar
GigaWatt


Gruppo:Utente
Messaggi:1729

Stato:



Inviato il: 20/8/2012,16:59

Ciao bolle!Oggi ho inserito il codice che hai postato nel pic,sembrerebbe girare anche sul fw 2.16 c ..... unico neo, non visualizzo i dati correttamente sul disp 16 x 2 ....



---------------
6 bosch csi 240 mono, 9 ldk 225 poly,
Outback flex max 60, psw 7 advance 4kw 48v,
24 elementi 400ah c 5 tubolari

 

PinoTux

Avatar
GigaWatt


Gruppo:AMMINISTRATORE
Messaggi:3443

Stato:



Inviato il: 20/8/2012,18:39

Si tratta forse della p di Amp che va a capo sul display 16x2 ? faccine/wink.gif



---------------
"Fatti non foste a viver come bruti, ma per seguir virtute e canoscenza"
http://iv3gfn.altervista.org/
http://pptea.altervista.org/

 

ronwal

Avatar
GigaWatt


Gruppo:Utente
Messaggi:1729

Stato:



Inviato il: 20/8/2012,20:34

non penso,non si capisce nulla ... domani riprovo!



---------------
6 bosch csi 240 mono, 9 ldk 225 poly,
Outback flex max 60, psw 7 advance 4kw 48v,
24 elementi 400ah c 5 tubolari

 

ronwal

Avatar
GigaWatt


Gruppo:Utente
Messaggi:1729

Stato:



Inviato il: 21/8/2012,17:26

Ciao Pino...oggi ho riprovato, ma visualizzo tutte le scritte ma con nessun valore numerico......sul compilatore vedo solamente la scritta start--stop ogni 5 secondi.....



---------------
6 bosch csi 240 mono, 9 ldk 225 poly,
Outback flex max 60, psw 7 advance 4kw 48v,
24 elementi 400ah c 5 tubolari

 

PinoTux

Avatar
GigaWatt


Gruppo:AMMINISTRATORE
Messaggi:3443

Stato:



Inviato il: 21/8/2012,19:58

Non so che dire, ho fatto la prova con l'ultimo firmare, il 216r...
Per il sensore di temperatura ho usato lm35 che già avevo, per gli altri due ho simulato le sonde usando dei trimmer (o potenziometri) collegando i terminali estreni a +5V e massa, i centrali ai rispettivi ingressi del PPTEA.
Regolando questi ultimi visualizzi il/i valore/i sul display, e sul compilatore il pacchetto Start/ i tre valori /stop.
altro non so...



---------------
"Fatti non foste a viver come bruti, ma per seguir virtute e canoscenza"
http://iv3gfn.altervista.org/
http://pptea.altervista.org/

 

ronwal

Avatar
GigaWatt


Gruppo:Utente
Messaggi:1729

Stato:



Inviato il: 21/8/2012,20:40

si vede che sulla versione 216 c non funziona....... cavolo un bel problema



---------------
6 bosch csi 240 mono, 9 ldk 225 poly,
Outback flex max 60, psw 7 advance 4kw 48v,
24 elementi 400ah c 5 tubolari

 

PinoTux

Avatar
GigaWatt


Gruppo:AMMINISTRATORE
Messaggi:3443

Stato:



Inviato il: 21/8/2012,21:24

CITAZIONE (ronwal @ 21/8/2012, 21:40)
si vede che sulla versione 216 c non funziona....... cavolo un bel problema

Non so perché usi la 216c, forse hai avuto dei problemi a programmare il PIC, immagino... e temi di rimanere "a piedi".. faccine/sick.gif



---------------
"Fatti non foste a viver come bruti, ma per seguir virtute e canoscenza"
http://iv3gfn.altervista.org/
http://pptea.altervista.org/

 

ronwal

Avatar
GigaWatt


Gruppo:Utente
Messaggi:1729

Stato:



Inviato il: 21/8/2012,22:07

non riesco a fare questa cosa per la mancanza di una porta rs232....e poi non lo ho mai fatto....mi hanno mandato la schedina con il sw piu' recente che ai tempi era la 216c .....qualche buon samaritano non mi potrebbe spedire un pic con l'ultima versione?....farei molto prima di poterlo fare io prima o poi.....



---------------
6 bosch csi 240 mono, 9 ldk 225 poly,
Outback flex max 60, psw 7 advance 4kw 48v,
24 elementi 400ah c 5 tubolari

 

NonSoloBolleDiAcqua

Avatar
PetaWatt


Gruppo:AMMINISTRATORE
Messaggi:13786

Stato:



Inviato il: 27/8/2012,10:37

Eccoci con la versione v1.1 del SolarPlatform...sono state aggiunte diverse cosette...il tutto è intuibile quindi non mi dilungo in spiegazioni...ma se avete domande ...ablate.
Cmq nella cartella Data vengono salvati i grafici di ogni giorno (alla mezzanotte) con la produzione giornaliera prodotta, ci sono i contatori dell'energia prodotta (sia giornaliera che totale), la possibilità di salvare in qualsiasi momento il grafico ( graphic.bmp). Successivamente con jumpy vedrò di integrarmi con il sito del PPTEA per gestire la parte web che darà la possibilità ad ogni utente registrato di vedere la situazione in tempo reale.
Un saluto
Bolle

ForumEA/PPTEA_IMG_FORUM/solarplatformv1_1.jpg



Link eseguibile: PPTEA SOLAR PLATFORM DOWNLOAD

Codice eabasic:

01 ' PPTEA SOLAR PLATFORM V1.0 DA VERSIONE FIRMWARE V2.16R o SUPERIORE
02 ' PIN 2 -> CADS1 -> Lettura tensione con partitore
03 ' PIN 3 -> CADS2 -> Lettura temperatura con sensonre lm35
04 ' PIN 4 -> CADS3 -> Lettura corrente con sensore ...
05 ' VISUALIZZAZIONE SU DISPLAY 2x16 e SUL PC MEDIANTE PPTEA SOLAR PLATFORM
10 CONSTANT SEPARATORE="/"
20 CONSTANT FATT_PROPORZ_TENSIONE=15.23
25 CONSTANT FATT_PROPORZ_CORRENTE=.225
30 CONSTANT REITERAZIONI=30
40 CONSTANT TEMPO_AGGIORNAMENTO=10
50 LCDWRITE=" PPTEA SOLAR"
52 LCDPOS=&H25
55 LCDWRITE="PLATFORM"
57 WAITS 2
60 LCDCLEAR
65 LCDPOS=&H19
70 LCDWRITE="PPTEASP"
71 :INIZIO_PROG
80 '----------------------------------------- LETTURA SENSORI
81 'T=CADS2
82 GOSUB :LEGGI_SENSORI
110 USBOUT=USCITAUSB '---------INVIO I VALORI ALLA PORTA USB DEL PC...COMUNICO CON IL PPREA SOLAR PLATFORM
111 WAITS TEMPO_AGGIORNAMENTO

200 GOTO :INIZIO_PROG
999 ' ---------------INIZIO FUNZIONI SENSORI -----------
1000 :LEGGI_SENSORI
1004 LCDPOS=&H11 ' TEMPERATURA
1005 CLR TEMP, VOLT, AMP
1006 FOR I=1 TO REITERAZIONI ' Effettuo la lettura contemporanea per REITERAZIONI volte
1010 TEMP+=CADS2
1015 VOLT+=CADS1
1016 AMP+=CADS3-512
1020 NEXT I
1025 STRTEMP=LEFT(TEMP*CAD_TO_TEMP/REITERAZIONI,5)
1026 USCITAUSB="START"& SEPARATORE & STRTEMP & SEPARATORE
1027 LCDWRITE=STRTEMP&CHR(223) &"C"
2005 LCDPOS=&H21 ' TENSIONE
2020 STRVOLT=LEFT(VOLT/FATT_PROPORZ_TENSIONE/REITERAZIONI ,5)
2026 USCITAUSB=USCITAUSB & STRVOLT & SEPARATORE
2027 LCDWRITE=STRVOLT & "V"
2105 LCDPOS=&H2A
2125 AMPERE=LEFT(AMP * FATT_PROPORZ_CORRENTE/REITERAZIONI,5)
2126 LCDWRITE=AMPERE & "A"
2127 USCITAUSB=USCITAUSB & AMPERE & SEPARATORE & "STOP"
2130 RETURN





---------------
Chi sa raccontare bene le bugie ha la verità in pugno (by PinoTux).
Un risultato se non è ripetibile non esiste (by qqcreafis).

 
 InizioPagina
 

Pagine: (72)   1   2   [3]   4   5   6   7   8   9   10   11   12   13   14   15   16   17   18   19   20  ...>    (Ultimo Msg)

Versione Mobile!

Home page       TOP100-SOLAR      Home page forum